| # Copyright 2022 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_INCREMENTAL_BUILD=1 |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_DESTDIR="${S}" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_SUBTREE="common-mk lvmd .gn" |
| |
| # This is where BUILD.gn is located. |
| # For platform2 projects, this indicates that GN should be used to build this |
| # package. |
| PLATFORM_SUBDIR="lvmd/client" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="Lvmd DBus client library" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/lvmd/" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="~*" |
| # Disable unittesting for client bindings. |
| RESTRICT="test" |
| |
| BDEPEND=" |
| chromeos-base/chromeos-dbus-bindings |
| " |
| |
| # Workaround to rebuild this package on the chromeos-dbus-bindings update. |
| # Please find the comment in chromeos-dbus-bindings for its background. |
| DEPEND=" |
| chromeos-base/chromeos-dbus-bindings:= |
| " |
| |
| RDEPEND="" |
| |
| src_install() { |
| platform_src_install |
| |
| # Install DBus client library. |
| platform_install_dbus_client_lib "lvmd" |
| } |