blob: 3fb4c4afde5e7c155e25d6037796e325a4253439 [file] [log] [blame]
# Copyright 2019 The ChromiumOS Authors
# Distributed under the terms of the BSD license.
EAPI=7
CROS_WORKON_PROJECT="chromiumos/platform/touch_updater"
CROS_WORKON_LOCALNAME="platform/touch_updater"
CROS_WORKON_SUBTREE="stupdate"
CROS_WORKON_OUTOFTREE_BUILD=1
inherit cros-workon user
DESCRIPTION="Wrapper for ST touch firmware updater."
HOMEPAGE="https://www.chromium.org/chromium-os"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="~*"
RDEPEND="
chromeos-base/chromeos-touch-common
sys-apps/st-touch-fw-updater
!<chromeos-base/touch_updater-0.0.1-r167
"
pkg_preinst() {
enewgroup fwupdate-i2c
enewuser fwupdate-i2c
}
src_install() {
exeinto "/opt/google/touch/scripts"
doexe stupdate/scripts/*.sh
local policies=(
"query"
"read"
"update"
)
insinto "/opt/google/touch/policies"
local policy
for policy in "${policies[@]}"; do
doins stupdate/policies/"${ARCH}"/stupdate."${policy}".policy
done
}
OSZAR »